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1. Introduction 

1.1.Description of application 

 
SoftONE-NEST is easy-to-use, powerfull CAD/CAM true shape nesting software for 
plasma, waterjet, oxyfuel, and laser machines. Application use the best methods for 
parts nesting and together with its database platform make a professional nesting 
solution for shipbuilding and sheet metal industries. 
Using a strong database system with network support make easy the integration 
with the existing customers ERP/MRP system.  
The main nesting engine provide the best functions for automatic and semi-
automatic parts arrangement. The application integrates the SoftONE-CNC smart 
post processor engine for a fast and complete set of NC instructions supporting the 
latest cutting technologies 
SoftONE-NEST nesting software can be used successfully as stand alone true shape 
nesting software as well as third part nesting solution of the existing customer 
shipdesign CAD/CAM system. 
Microsoft blue style graphical user interface (GUI) makes it easy to learn.It is based 
on the latest .NET technology. 
Technical Specification: 

 Operating system: Runs on Windows 7, Windows XP or Vista® operating 
systems; 

 Import from: AutoCAD DXF, Aveva Marine gen files, Nupas, Smart Marine 
3D DXF files; 

 User customizable ESSI & G-Code post processors; 
 Post processors for multiple machines;  
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1.2 SoftONE-NEST Features 

 

Main Features: 

 Automatic parts imports from CAD systems: DXF, NUPAS, SM3D, AVEVA Marine ; 
 Automatic CAD file correction and error notification; 
 Automatic or manual nesting; 
 Powerful nesting algorithms and optimized tool path research; 
 True Shape Nesting; 
 Array Nesting; 
 Part In Part Nesting; 
 Smart bridges nesting: automatic or manual bridges 
 Drag, drop, and bump features; 
 Automatic NC tool path generation and optimization; 
 Automatic and manual lead-in/out features; 
 Automatic part position numbering, productions sketches and reports; 
 Integrate the powerful algorithms from SoftONE-CNC NC post processor application for 

fastest generation of NC files; 
 ESSI & EIA (G-Code) standard post processors included; 
 User customizable post processors. 

Advantages: 

 
 Optimal rectangular material utilization to reduce scrap ; 
 Management of parts – parts inventory; 
 Management of plates – plates inventory; 
 “Real Time” counting of the nested parts; 
 “Bridge nesting” reduce the pierces machines processes; 
 Maximum flexibility in file conversion and importation; 
 Custom shapes can be saved into standard part library for future use; 
 Integration with different CAD/CAM systems like Aveva Marine and Nupas; 
 Microsoft database system for storing objects and easy reports generation; 
 Full functionality of machine technology achieved ; 
 Easy Post Processors user addins according with customers CNC controllers 

configuration; 
 Export nesting plates as DXF using closed polylines for each part for an advanced 

compatibility with machines which can convert directly DXF nesting files; 
 Full productions reports: BOM, nesting lists; 

 
 
 
 
 
 
 
 
 

http://www.website-magazin.ro/magic/onesoft/node.php?n=cnc-post-processor
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1.3 Installation and Licenses 

 
Installation of the SoftONE-NEST software can be performed very simple, launching 
setup.exe file from installation kit. Follow the information on the screen to complete 
the software installation. 

After installation, if the dongle device is not present, the application will not start 
working. The licenses protection system consists in a dongle USB device or a license 
key. It comes together with the software installation kit and it is already 
programmed according with the number of acquired licenses. In order for the 
program to operate correctly, the dongle device must be inserted into a USB port on 
the computer at all times. If the dongle key is removed during operation of the 
program, the software will not function correctly. 

 
 

1.4 Technical Support 

 
ONESoft offers all customers free technical support for the first year after purchase. 
Additional support is available through the maintenance and support program. In 
some cases our staff will offer to investigate the problem with your data file. In this 
case, we advise that you compress the data file (for example with WinZip) and e-mail 
it to us. We will investigate the problem and forward a solution to you. 
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2. Operation Procedure 
 

2.1 Usage notes 

 
 Zoom and Pan functions: When work in SoftONE-NEST, two of the most 
common operations are zooming and panning the work space. Zooming allows one to 
either examine a narrower view of the work space in more detail or to review a wider 
overview. For zooming up, 2 mouse click points are necessary. Two or more zoom up 
commands can be performed as necessary for increase  area view.  Autoscale enable 
a whole view of work space. Panning enables one to view a different area of the work 
space that is not currently visible.  
  
For easy operation, shortcuts key  are allocated for zoom and pan functions: 
  -  “Z”  for zoom IN 
 -  “W” for PAN 
 -  “S” for Autoscale 
 
 Zoom IN  – Menu->View-> Zoom IN function, “Z” key shortcut – zoom to 
display an area specified by two opposite corners of a rectangle window: 

- click for set the lower left point of the zoom rectangle 
- while hold down the left mouse click ,click for upper right point of the 

zoom rectangle 
- click on autoscale button for view of all workspace.  

Zoom Mouse Wheel: Perform a transparent zoom operations when you scroll the 
middle mouse wheel :moves wheel forward zooms in; moving wheel backwards zooms 
out. 

Autoscale  -  Menu->View -> Autoscale function “S” key shortcut   

- Enable a whole view of work space (nesting drawing) 
   

Pan  – Menu->View-> Pan function, “W” key shortcut or mouse wheel 
click: 

- draws a straight line from the centre of the graphics screen to the 
current  

cursor position, as soon as the cursor is moved by any amount. The User can then 
move the cursor in any direction to a new position and when the left-hand button on 
the mouse is clicked the system makes this position to be the new centre of the 
graphics window. Any graphic entities on the screen will appear to move in the 
opposite direction, and by the same amount, to the movement of the cursor. The 
scale of the drawing and the associated graphics entities are not changed by this 
operation.  
 



 

 8 

 
Accept  or reject  buttons: 
 
For finalizing of any base function (e.g. transform or BUMP operations), the 
“Operation complete” button should be clicked  (or press return from keyboard)  
For exit from the current function, the “Cancel” button  should be clicked (or 
press ESC on the keyboard).  
For easy searching for items, all selection lists used by system, can be sorted by 
clicking on the desired columns head. In this way, the lists “works” similar with  thw 
standard file explorer lists in windows operating system, which are familiar to any 
windows user, making the software operation more easily. 
 

2.2 Nest from DXF  

In order to nest parts designed in other CAD system like Autocad, the 
drawing for each part should be available in DXF (Drawing Exchange Format) file 
format.  
 
The DXF layers should map the SoftONE-NEST layers settings from Preference 
menu: 
 

 
 
The DXF layers corresponding with the machine processes: 
 
Outside: outer contour of the part 
Inside: inside contour of the part – hole(s) 
Marking: marking lines 



 

 9 

 
From preference menu, you can adjust the layers name to map your DXF parts 
layers name.  
 
For importing the parts, the following steps should be performed: 
 

1) Start SoftONE-NEST software 
2) Import the DXF part files 

- Select  button or File->Import DXF part function from menu ; 
- Select the folder where the DXF files resides ; 
- Select the DXF part file  -  a graphical preview of the part will be 

shown; 
 

 
 
- Select the import type:  

 Interactive: manually add/modify the part properties 
(thickness, material quality etc.)  

• Press “Open” button. A new form will appear; 
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The following part properties fields are available: 
PartName: name of the part (default value is DXF file name) 
Quantity: necessary quantities 
Qual: material quality 
Thickness: material thickness 
Pos No: position number (part I dentification  in workshop drawing); 
Unit: name of the unit (block) which the part belong to. 
 

• Click “Import”  button. 
 
 Batch: For direct import the DXF parts into database: if the 

part properties are not present inside of the DXF file, the 
thickness and material quality should be input in the form. If 
more than one file is selected, the thickness and material 
quality will be applied for all selected DXF files 
 
• Click “Open” button. 

 
 

3) Start a new nesting or open an existing nest job 
 

a. Input nesting job required parameters: nesting name, quantity and 
the raw plate dimensions: 

- “By name”: select the raw plate (sheet) from the inventory  
- “By dimensions”: input manually: dimensions, thickness and quality of 

the raw plate.  
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b) click “OK” button for start a new nesting 
 

4) Nest the parts  
- Get the part with the Nesting->NestParts-> From Explorer menu 

function  or with   button. 
 

 
 
- Drag the part on the plate. The part will be attached to the mouse 

pointer. Positioning the part on the plate using the mouse. After 
positioning on the nesting plate, use the “Transformation functions” 
and BUMP functions to arrange it on the plate. After finish use 
“Operation complete” function. After complete, the part will be shown 
on the “Nest Explorer ” tree window. 
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- Arrange the part on the nesting  
 

a) Select desired part with the Nesting-> Transform part 
function from menu or click the  button 

b) Select the  SoftONE-NEST true shape nesting  functions: 
• Transform parts functions: move, rotate, mirror 

transformation 
• SMART BUMP functions for automatic movement to a 

distance determined by the system, in a specific 
direction given by the user. The distance is the largest 
distance the part can be moved without overlapping any 
other par or the parent plate Default clearances 
between parts and between a part and the parent plate 
is taken into account when the distance is determined. 
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5) Automatically or manually add bridges 
• Automatic: Edit->Bridges-> Automatic menu function or 

with  button; 
• Manually: Edit->Bridges-> Insert menu function or with 

 button; 
 

6) Automatically or manually add leads IN/OUT 
 

• Automatic: Nesting->Starts -> Automatic menu function 
or with the  button; 

• Manually:Nesting->Starts -> Burn menu function. 
 

      7) Automatically generate the NC file for: 
 All machine processes: Generation-> Complete Path function or 

with  button 
 Marking machine  processes: Generation-> Marking Path 

function 
 Cutting machine processes: : Generation-> Cutting Path 

function 
 

The system will optimize the machine paths automatically and generate the NC code 
according with the selected post processor setting file from Tools-> Preference menu 

 
 

- a preview of the NC code will be shown in the dedicated NC toolbar 
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7) Simulate the NC machine paths  
- Activate SoftONE-NEST  Simulation  mode: View-> Simulate function 

or click on  button  
- Change the simulation speed from SoftONE-NEST Simulation toolbar 

    
 
 

 
Fig1: Sample SoftONE-NEST nesting job 
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3. Administration 
 

3.1 Admin overview 

The Project is a fundamental concept in SoftONE-NEST, and all nesting work takes 
place within a project. Post Processor settings are defined separately for all projects 
through a xml definition files. 
A nesting project contains a database file. The project database file owns a number of 
tables: each table type has a different database schema; that is, the element/attribute 
structure is different. 

3.2 Nesting database 

Database type: 
 
The nesting databases project is a Microsoft Access database type. The system comes 
with a template default databases located in the “Template” folder in the main 
installation folder. User specific databases can be easily created and placed on the 
other location on the disk. Also, it can be shared across the network as necessary.   
For information about setting up a new project database, see chapter 3.3: Setting up 
a new project  
 
How Databases are Stored 
The databases consist in a 2 MDB database files, stored in the a database  directory: 
the main project database and the MISC.MDB miscellaneous database (for 
miscellaneous project objects).  
The main project database filename can have any  name, but, for a easy 
identification,  the following format name is better to be used : 
XXXnnn 
where xxx is the Project Code, for example, abc, and nnnn is a project number, nnn 
is the database number. Databases can be stored in a different area, that is a 
different directory from the default “DB” directory. This may be necessary, for 
example, if disk space is a problem. The directory must be created before the 
database is created. For network environment, the database should be shared. The 
security permissions of the file should be the “write” acces. 
 
 
Note: The MISC.MDB should be copied from the template project without changing its name 
and should exist for each project in the project directory! 
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3.3 Setting up a new Project 

When you first start the SoftONE-NEST application, it search for the default 
installation nesting database named “Template.mdb”  which is located in the DB 
folder of the application. If the database  not found, a error message will be shown.  
 
 

 
 
In order to be able to start nesting jobs, the system should be connected to a 
SoftONE-NEST database. Connection to database can be done from Tools-> 
Preference menu, “Select” button. Through a standard browse file dialog, the nesting 
database can be selected as current working database.  
 
For each nesting project, SoftONE-NEST use 2 mdb database for storing nesting 
objects : 
 

- The main database: store all parts & nesting information; 
- Miscellaneous database (MISC db): store other necessary project 

information: plates & parts inventory, sketches etc. 
 
To set up a new project, the following steps are necessary: 
 

a) Copy the project template databases located in the Template 
folder of application in your projects directory: for example: 
C:\Projects 

b) Rename the main database template.mdb, according with 
your nesting project: for example abc123.mdb 

c) Copy the MISC>MDB database to the new db project 
directory 

d) Start the SofONE-NEST application and select the main 
created database from Tools>Preference menu database page. 
The current selected database name & path are shown in the 
database tab page. 

e) Change the project information according with your project: 
• Name: project name 
• Code: project code 
• Description: project description 
•  
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f) Save the settings; 
g) Restart the application. 

 
 
Network environment: 
 
For sharing nesting data to other users, the database project folder should be shared 
in across the network. For store the nesting jobs, the users which will access the 
SoftONE-NEST database should have the “write” rights security rights. 
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3.4 Projects Settings 

Projects settings can be modified from Tools-> Preference menu and consist in the 
following “Tabpages”: 

- Nesting Project Settings 
- Application settings 
- Post Processor settings 

 

 
 
“Nesting” page settings: 
 
Nesting: 
Outside direction: enable the direction for outer part contours: 

”CW” clock wise ; CCW counter clockwise  
Inside direction: enable the direction for inside (holes) part contours: 

”CW” clock wise ; CCW counter clockwise  
Work Sequence: select the desired cutting order:  

“By process”: the cutting order will be selected optimized according 
with processes order: parts inside holes, holes, outside contour; 
“By Part”: the cutting order will be selected optimized for each part 

Part Distance: Distance between parts. This distance is a minimum distance which 
is default for the transformation functions BUMP. The functions transform plate 
parts in a way that the distance between the indicated parts is never less than the 
default distance. 
Plate Distance: Distance between parts and raw plate edge. This distance is a 
minimum distance which is default for the transformation functions BUMP. The 
functions transform plate parts in a way that the distance between the part and the 
raw plate edge is never less than the default distance. 
Bridge Width: Width of bridge 
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Sketch: 
 Form Name: name of the default nesting form which will be used; 
 Font Name: name of nesting sketch font; 
 Font Size: nesting sketch font size; 

Add Parts Table: automatically generate the parts table in the nesting sketch 
Add Pos/PartName: identification string used for parts in the nesting sketch; 
Show Idle: show idle paths in the nesting sketch; 

Bevel: 
Enable corner loops: Add corner loops for each part; 
Type: Corner loop type: triangle (default( or circle; 
Length: side length of triangle corner loop; 
Radius: circle radius of corner loop. 

 
“AutoNesting” page settings: 
 

 
 
Autonest type: type of autonesting used method: quick, fine, Optimize by col. – 
Optimize mode should be satisfactory in most cases. 
Sort Parts:  
 Surface: nesting will start from bigger surface parts to lowest surface parts. 
 Perimeter: nesting will start from bigger perimeter parts to lowest perimeter 
parts. 
Plate sheets: Single – single plate sheet will be used 
  Multiple – multiple plate sheets should be used: 

Nest Name: string used for generation of nesting name 
jobs 
Multi Sheer: size of the sheet which will be used. 

Part angle: The rotation angle increment of the autonested parts. 
Scrap: Maximum allowed scrap for single part nesting. 
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Nest part in hole: automatic nesting of parts in holes 
 
“Leads” page 
 
The outside leads (for outer contour) and inside leads (for holes) can be changed in this page. 
For “0” value of lead in/out, you can switch on off the corresponding leads.  
 
Note: You should take into account about the distance between parts when modify these values for 
avoiding the overlapping! 
 

 
 
Line all : all leads will be added as lines segments 
Arc all : all leads will be added as arcs. 
 
Lead IN length: length of the lead for the first “entry” lead 
Lead OUT length: length of the lead for the  “out” lead 
“Post Processor” page 
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Postprocessor: select the desire postprocessor for output the NC files 
Description: edit the description of the postprocessor 
Output extension: modify the extension of the NC file 
Burn Type: select the cutting type by selecting : Gas or Plasma 
Code format: Select the code format by clicking Incremental or Absolut 
Controller type: Select the output NC code standard by clicking ESSI or G-Code 
 
“NC Processing” and “Bevel” pages: 
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Processing settings are used during post-processing when generating the NC code. You can 
modify the instruction taking into account about the settings of your machine controller. 
 
See “NC POST PROCESSOR” chapter for more information about customization of the 
post processor output codes. 
 
 
“Part Import” page: 
“General” page: standard DXF part import interface parameters 
DXF Layers can be changed accordingly to CAD parts geometries layers Default 
values are: MARK  for “this side” marking, MARK1 for “other side”  marking (on the  
opposite side); OUTSIDE for outer contour, INSIDE for holes, TEXTS for labeling 
text, TEXTP for part production texts (e,g.: position, thickness, quality); 
The system will detect automatically inside of DXF file the part properties fields.  
The following tags are currently available for automatically part production imports 
(part properties): 

“U:” tag for unit name: should be followed by desired unit name; 
“T:” tag for part thickness: should be followed by material thickness; 
“M:” tag for material quality; should be followed by material quality 
value 
“P:” tag for part position identification: should be followed by 
workshop position number. 
“N:” tag for number of parts; 

 
Maximum radius: set the max radius that are supported by your cutting machine. 
Check the controller’s documentation for setting this value. 
Snap tolerance: The length of the gap between elements of a shape that SoftONE  
will jump or connect into a single shape. This compensates for lines not actually 
joined in the original DXF files. Snap tolerance should be GREATER THAN or 
EQUAL TO the length set in Erase Elements <. SoftONE-NEST automatically 
adjusts two elements to the same meeting point. The program automatically 
determines which element has to be adjusted to close the gap causing the least 
change in the path. 
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“Nupas DXF” page: customized interface for importing DXF parts from NUPAS 
CAD/CAM system. Two options are available: “By layer” and “By Color”. 
 

 
 
“Database” page 
Current used nesting database.  
Read Chapter 3.3 , “Setting up a new project”  for detailed information about setting 
up the nesting project database. 
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3.5 DB Utility 

The administration tasks of the current working project database can be done from 
the Tools->DB Utility menu: 
 

a) List and delete parts objects; 
b) List and delete nesting objects 
c) Unlock nesting objects. 
d) Import parts from other SoftONE project database; 
 

 
 
 
In the database name list can be selected the database for administration: Nesting 
DB or Parts DB 
 
Nesting DB table operations: 
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- List: list nesting objects according with the “Object name” filter. 
Standard information can be found in the associated list view: Object 
Name, Size, Lock state, Version, Modified, Accessed, Date. 

-  Unlock: unlock a nesting object: in a network environment, when a 
user open a nesting, the system lock the nesting object for avoiding 
opening by other user. Sometimes the nesting remain locked (crash or 
failure appear) so, a unlock operation should be performed.  

- Delete: delete a nesting object from the project database. 
 

Parts Table DB table operation: 
- List: list parts objects according with the “Object name” filter; 
- Delete: delete a part object from the project database; 
- Import parts from other SoftONE database project:  

 Select the database from which you want to import parts with 

 button;  
 Select the desired parts from the “object list”.  
 Import the selected parts into the current database with    

 button  

4. Parts 
 
Parts are SoftONE-NEST’s nesting units. For nesting, SoftONE-NEST use the 
“nests parts”. It does not nest geometry.  
Parts are closed contours geometries. Parts are created automatically in SoftONE-
NEST. Open geometry is automatically detected and there is an opportunity to 
correct it. 
 When a part is created, internal and external contours, marking lines and labels are 
recognized and explicit identified on a part. The area, weights of the parts are 
automatic calculated. The basic production information like position number, unit, 
material grade etc, should be added before the part is created.  
 
A part, with all its related information will be stored in the project database and 
subsequently recalled for modification or re-use in a repeat of the same context or for 
use in a different context. 

4.1 How SoftONE-NEST organize CAD geometries 

Entities are the lowest level of geometric information. SoftONE-NEST presently 
supports the following CAD entities: 
 
 
· lines 
· arcs 
· circles 
- polylines 
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If you use CAD blocks to group your drawing data, please explode them just before 
you write the DXF file. You can then use the undo command to restore the grouped 
state. 
 
Parts consist of a number of connected entities. Part may be closed, i.e. the end of 
the last entity connects with the start of the first entity, or a part may be open. 
Closed parts can be checked for direction of travel, i.e. clockwise or counter 
clockwise. Open parts cannot be checked for direction. It is the operator's 
responsibility to check the shapes.  
 
Layers are logical levels in a CAD drawing. They contain entities. SoftONE-nest 
assigns a meaning to each layer. In order to map the DXF layers to SoftONE-NEST 
processes, the DXF part geometries should be situated on the layers.  The following 
default layer names are recognized by SoftONE-NEST. You can change the default 
layer names to suit your needs, from Tools->Preference menu. 
 
· MARK shapes are marked on the plate with a scribing unit. 
· INSIDE shapes are cut with the kerf towards the inside of the path. This 
layer is used for through holes. 
· OUTSIDE shapes are cut with the kerf set towards the outside of the closed 
shapes. 
Entities on other layers are omitted. 
 
Note: If outer contour and inner (holes) contour are on the same layer, SoftONE-
NEST try to automatically identify the holes and assign the geometries on the 
SoftONE-NEST “hole” layer. 
 
General part DXF Import settings: 
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Import filters: 
Maximum radius: set the max radius that are supported by your cutting machine. 
Check the controller’s documentation for setting this value. 
Snap tolerance: The length of the gap between elements of a shape that SoftONE  
will jump or connect into a single shape. This compensates for lines not actually 
joined in the original DXF files. Snap tolerance should be GREATER THAN or 
EQUAL TO the length set in Erase Elements <. SoftONE-CNC automatically 
adjusts two elements to the same meeting point. The program automatically 
determines which element has to be adjusted to close the gap causing the least 
change in the path. 
 
DXF Layers: 
Outside cut: Layer assigned to outer contour geometries; 
Inside cut: Layer assigned to inner contour geometries (holes); 
Marking this side : Layer assigned to marking lines geometries. 
Maring “other side”: Layer  assigned to the opposite part side); 
Labeling texts: Layer assigned to text which should be printed on the part; 
Part production texts: Layer assigned to part properties (e,g.: position, thickness, 
quality *); 

 The system will detect automatically inside of DXF file the part properties 
fields.  The following tags are currently available for automatically part 
production imports (part properties): 

“U:” tag for unit name: should be followed by desired unit name; 
“T:” tag for part thickness: should be followed by material thickness; 
“M:” tag for material quality; should be followed by material quality 
value 
“P:” tag for part position identification: should be followed by 
workshop position number. 

4.2 Creating nesting parts from DXF 

4.2.1 Nest Preparation within a CAD Program 
 
SoftONE-NEST import parts geometries from DXF files. Any CAD program that can 
export the drawing in DXF format and support layers can be used. The CAD part 
drawing has to meet certain specifications to be able to be processed. The operations 
described here are specific for using SoftONE-NEST together with AutoCAD, but are 
essentially the same for any other CAD program that can export DXF files.  
 
Steps involved: 
 
1. Prepare the CAD drawings for all parts. 
3. Explode all blocks that you might have in your drawings. 
4. Export the part drawing to a DXF file for each part; 
5. Use SoftONE-NEST import function to automatically import the parts; 
6. Input the necessary quantities for  imported parts; 
7.         Nest the parts using SoftONE-NEST software. 
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4.2.2 Import DXF  parts in SoftONE-NEST 
After creating the DXF part, you can easily import it into SoftONE-NEST database. 
Depending of the requested detailed level part information, 2 types of dxf parts 
import can be performed: 

a) Interactive (graphical); 
b) Multiple files from folder; 

 
A) Interactive 
 

Steps involved: 
 

- Select  button or File->Import DXF part function from menu ; 
- Select the folder where the DXF files resides ; 
- Select the DXF part file  -  a graphical preview of the part will be 

shown; 
-  

 
 
- Select the import type:  

 Interactive: for manually add/modify the part properties: 
thickness, material quality etc.  

• Press “Open” button. A new form will appear 
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The following part properties fields are available: 
PartName: name of the part (default value is DXF file name) 
Quantity: necessary quantities (default 1 pc); 
Qual: material quality 
Thickness: material thickness 
Pos No: position number (part I dentification  in workshop drawing); 
Unit: name of the unit (block) which the part belong to. 
 

• Click “Import  button. 
 
 Batch: For direct import the DXF parts into database: if the 

part properties tags are not present in the DXF file, the 
thickness and material quality should be input for the selected 
DXF files, otherwise an error notification will be shown. 

• Click “Open” button. 
 

SoftONE-NEST DXF import interface check the part for errors, e.g.: opened contour, 
double elements etc. If the part contain geometries errors an error message will be 
displayed on the screen. The operator should  correct the part  in the CAD program 
and import the part again. 
 
B) Multiple parts import from folder. 
 

Steps involved: 
 

1) Open SoftONE-NEST Batch import interface from File->Batch Import 
DXF Parts; 

2) Open the DXF parts folder with  button; 
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3. Click  import button for automatically import the selected part into DB; 
 

 
 

A progress bar will show the stage of the import process. 
 
Note: The DXF files should contain the tags for part production information fields. If 
not, a error message will be generated. The system add 1 (one) pc for each imported 
part as default in the plate inventory. The necessary quantities can be modified 
through “Parts inventory” interface.  
See “Parts Inventory” from chapter 5 “Material Management” for more information 
about how to manage the parts quantities for your project. 
 
 

4.3 Finding and retrieving parts 

For finding the parts, DBUtility function menu can be used. It can be found in Tools 
menu. 
The parts can be filtered by name.  
For delete a  part(s), the “Delete” button should be used. If the part is already nested 
a confirmation message will inform the user about the part nesting status. 
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For retrieving a part in a nesting job, the  “Nest From Explorer” or “Nest part by 
name” functions should be used. For more details, see the “Nesting” chapter.  
 

 
 
Note: A nesting job should be opened for this operation 

4.4 Import parts from other CAD/CAM software 

SoftONE-NEST can automatically import parts from the following  CAD/CAM 
shipdesign systems: 
 

1) Aveva Marine (.gen & .DXF “ppanparts” file); 
2) Smart Marine (.XML part data file); 
3) Nupas DXF part files. 

 
For detailed information about these features, please contact ONESoft technical 
department, office@onesoft.ro. 
 

mailto:office@onesoft.ro
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5. Material Management 
 
SoftONE-NEST manages the necessary materials and controls the quantities of each 
the nested part through the material management features: “Parts inventory” and 
“Plates inventory” 
 
5.1  “Parts inventory” The Part Inventory Database stores a list of parts that need to 
be cut more than once. This list could be used for assemblies or for repeated parts . 
Once this list is created, it can be accessed within SoftONE-NEST when perform 
nesting parts.  
 
The party inventory form can be launched from Tools->Materials->Parts Inventory 
menu function: 
 

 
 
 

A customized part list can be created according with the project specification. 
At the import step, by default, the system asign 1 pc for each part (for batch import 
type). It can be modified  by a double mouse click on the selected part in the parts 
list. After finishing, you should save the parts quantities into Parts inventory 
database. When all parts have been added to the part list with correct quantities, 
material and properties, close out of the Parts Inventory screen by clicking on 
standard form close icon. 
Note: When start the nesting jobs, the system will  count the nested parts according with the 
parts list quantities from Parts Inventory DB. 
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5.2 Plates inventory  
 
The Plate Inventory Database stores a list of all the plates stored at the facility. 
Once this list is created, it can be accessed within SoftONE-NEST so that a user can 
easily see what he has available to him to nest on. Plate Inventory is also the 
location where the unnested portion of a plate is stored as a remnant or skeleton.  
 
The open Plate Inventory interface,  click on “Tools menu, Materials->Plates 
inventory” 
 

 
 
The followings functions are available: 

 “Add” Button: Create a new plate. The follwing fields are required: 
  - Name: plate name 
  - Type: plate type 
  - Dimensions:  

X Dimension - Length of plate 
Y Dimension - Width of plate 
Material - Type of material the plate is made of 

  - Stock quantities: number of available plates; 
  - Date: creation date 

  You should press the “accept”  button for saving the plate into 
database. 

This will automatically calculate the area, weight, total weight 

 “Delete” Button: Remove a plate from the inventory database. 
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”Refresh” Button: Read the all plates data from database and calculates how many 
plates are used by nesting jobs. The corresponding colums in the plates list will be 
filled accordingly. 
. 

 
 

”Excel report” Button: Export the plates inventory list to Microsoft Excel .csv file. 
 

Note: To change plate information in your Plate Inventory Database: In the list of 
plates, locate and double-click the plate you want, and then change the information 

as needed. After finish, press the “Accept” button   for storing the modification in 
the plate inventory database.  
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6. Nesting 
 
SoftONE-NEST offer an extensive functions to perform advanced true shape 
nesting. 
SoftONE-NEST support: 
 

• Full manual true shape nesting; 
• Automatic leads adds; 
• Automatic nesting sketch generation. 
 

Before starting a nesting process, a nesting job should exist in the work space; a new 
nesting job can be created, or a previous saved nesting job can be used. 

6.1 Nesting job 

6.1.1. Start a new nesting job 

To start a nesting job, the new nesting job form from “File->New nesting job” 
menu function should be launched. A new nesting job can be initiated also  by 
clicking on new nesting button   from standard toolbar.  
 

 
 
Two options are available for defining the plate parameters of the nesting job: 
“Plate By Name “and “Plate by dimensions”. 
 
General parameters: 
Nest Name: name of the new nesting job 
Quantity: quantity of the nesting sheets (default =1) 
Date: Date of the nesting job (by default current date) 
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Project: Current selected project. 
 
Plate By dimensions.  
Required fields: 
Length: length of the sheet 
Width: width of the sheet 
Thickness: thickness of the sheet 
Quality: material grade 
 
Plate By Name  
Select the plate name & dimensions from the plate inventory list according with 
defined plates in inventory. See “Plates Inventory” from chapter 5 “Material 
Management” for more information about how to manage the plates & parts 
inventory for your project. 
 
 
Note: For the current nesting, the plate sheet dimensions can be changed with 
“Exchange Raw Plate” function from Edit ->Plate menu. 
 

An existing nesting job can be opened by File->Open Nest” menu function or 
 standard button. 

After selecting a nesting job, a preview image of will be shown in the special 
“preview” window area. Also, useful information are shown in the nesting list: 

- Dimensions: length, width, thickness; 
- Material quality; 
- Creation Date; 
- Nesting status; 
- Usage area; 
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For a quick searching of a nesting job, the nesting list can be sorted by clicking on 
the desired column. 
 

Save nesting job 
 
For saving the nest job, the “File->Save nest” menu function should be used. As 

result, the nesting job will be saved in the current project database. If the nesting 
sketch was created, it will be saved in the project database as well. 
 

6.1.2.  Nesting job status 

Nesting job status is a “flag” which indicate if the status of the nesting job. In this 
way, is possible to control which nesting are in work, complete or launched in 
production workshop. 
 The followings nesting status are available: 
 

- “Pending” : nesting is not finished, nesting sketch is not inserted and 
NC program was not generated; 

- “Complete”: nesting are finished, but not sent yet in production; 
- “In Production”: nesting is finished and sent to the cutting production 

workshop; 
 

After finishing a nesting job, is possible to change its status according with the 
nesting stages. All status of the nesting jobs are displayed when the “open nesting “ 
menu function is involved. Also, the nesting status of all nesting job  can be verified 
using the BOM reports. For more information about report generation, see “Nesting  
sketches and reports” chapter. 
 
NOTE: If a nesting job has “In production” status, all modification functions are disabled. It 
still can be modified only after changing its status to “Pending”. Some warning messages are 
displayed when changing the status back to “Pending” or when opening  the nesting jobs 
launched in production. 
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6.2 Manual nesting 

SoftONE-NEST offer advanced function for a manual true shape nesting process.  
The parts nesting can be performed in 2 ways: 
 

1. “Drag and Drop” from Parts Explorer List  
2. “By name” standard procedure. 

 
The most used nesting procedure is “Drag and Drop” which offer fastest nesting way 
and very good control of the number of parts which should be nest. 
 
Steps involved: 

6.2.1. Starting a manual nest 
A nesting job should exist in the workspace before starting a manual nesting 
process. 

6.2.2 Adding parts 
 
For adding parts to the existing nest, 2 functions can be used: 
 

- From Part Explorer Nesting->Nest Parts->From Explorer” menu 
function or  button; 

- By Name: Nesting->Nest Parts -> By name” menu function or  
button. 

 

1. From Parts List Explorer  
 
This function will load the parts in the part explorer for the nesting tasks. The parts 
can be added to the nesting job using “drag & drop“ or “double click” features. Before 
loading, the parts can be filtered by name, thickness and quality fields.  
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Filtering fields: 
Part Name: Part name search string; 
Thickness:  Thickness of the parts; 
Quality: Material grade of the parts; 
Parts already nested: if selected, the system will load in the explorer list the already 
nested parts; 
Keep existing parts:  if selected, the system  will be kept the already loaded parts in 
the part explorer list. 
 
After press “OK” button, the “Parts Explorer List” will add the parts according with 
your selection. 
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Available information: 
Preview: Part preview picture 
Pcs: Number of parts pieces which should be nest are retrieved from Parts Inventory 
database: default is “1” pc;  
Area: part area 
Name: part name 
Quality: Material grade 
 
Note: The “Pcs” value for a part are in accordance with the stored value through Parts 
Inventory interface (more info at Material management chapter). When nest, the system will 
count the nested parts. After saving the nest, involving the “refresh” function by right mouse 
click on parts explorer list, the list will count the nested parts and show the remaining 
number of parts which should be nest! 
Thus, a real time control of the counting of nested parts is done, avoiding material loses. The 
system use 3 colors to show the part status in the “parts explorer list”: 

- Green: all available parts was nested; 
- No color: there are still parts available; 
- Red: the number of the nested parts is greater than defined number of parts 

in inventory database! 
 
You can sort the parts by clicking on the corresponding columns list. By default the 
list is sorted in descending order by “Area” column. You can change the list view by 
a list context menu which can be accessed with a  mouse “right click”. A standard 
view modes are available: “Large icons, List, Details, Tile” . 
 
 “Drag and Drop” nesting procedure:  “Drag “the desired part over the nesting area 
and “Drop “it in the desired zone. 
 Move the mouse pointer in the work space area. An outline of the part is attached to 
the mouse pointer.  
Position the mouse pointer where the part should be placed on the sheet.  
Select left mouse button. The part is placed in the location of the work sheet and 
remain selected for future transform operations; See ”Arrange parts on the nest” 
chapter for details. 
Press operation complete button for leaving the part in the mouse location position. 
The value from “Pcs” column will be decreased accordingly.  
Repeat the above steps for adding more parts to the nesting sheet. 
“Double click” parts nesting:  perform a mouse double click on desired part from 
parts explorer list. The system will try to find the “next” available position of your 
part into the nesting job. 
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Anytime, the system can give information about the nested parts in the 

current nesting job. The information are shown by involving the “Edit->Part-
>Property” menu function or by  button. 
The following information are displayed:Part identification, Part information, 
Nesting information, Part’s property. 
 

 
 

2. By Name 
 
Each part will be selected manually from the selection form.  
After selecting a part in the list, a preview image of the part will be shown in the 
special preview area. 
 
The following options are available: 
Sorting the parts: parts can be sorted by part name, thickness, quality or area by 
clicking on the corresponding  column of the  parts list   
Filtering the parts: available filters: name, quality ,thickness or nesting status. 
 
After selection you can place the part on the nesting area.  
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Move the mouse pointer in the work space area. An outline of the part is attached to 
the mouse pointer.  
Position the mouse pointer where the part should be placed on the sheet.  
Select left mouse button. The part is placed in the location of the work sheet and 
remain selected for future transform operations; See ”Arrange parts on the nest” 
chapter for details. 
Press operation complete button for leaving the part in the mouse location position. 
The value from “Pcs” column will be decreased accordingly.  
Repeat the above steps for adding more parts to the nesting sheet. 

6.2.3. Arrange parts  on the nest 
After click on “Nesting-> Transform Part ” menu function or  button, the 

system ask for selection of a parts(s). One or parts can be selected by clicking inside 
of the part or by specify a rectangle window with the mouse. After finishing the 
parts selection, click on the “Operation complete” button . The arranging 
function from “Transformation functions” and “BUMP” toolbars will be activated and 
become available for transform part operation. 
 

The “Transformation functions” are used in a transformation sequence, when 
a plate part is to be positioned. Thus, they are actuated one after the other, until the 
part is properly positioned.  

 

- Transformation functions toolbar 
 
With the BUMP functions, a part can be moved a distance determined by the 
system, in a specific direction given by the user 
 

 - BUMP functions toolbar 
 
Accept  or reject  buttons: 
 
After selecting the part(s)s or for finalizing the transformation functions  (BUMP, 
ROTATE, MOVE etc), the “Operation complete” button should be clicked  (or 
press return from keyboard). 
 
Note:You can select also the parts by specify by two opposite corners of a rectangle window: 

- click for set the lower left point of the select rectangle 
- click for upper right point of the select rectangle 

All parts inside of drawn rectangle will be selected. A standard selection by clicking inside 
part’s area can be used in combination.  
Advantages: when you need to transform more parts, reduce the time for parts 
selection. 
 
Exiting from the current function can be performed with the “Cancel” button (or 
pressing the ESC key on the keyboard). As result, the part will go back to the initial 
state before the function was issued. 
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Note: When involve the transform function, first, you should select one or more parts. You 
can select it one by one (with a mouse click) or defining a mouse rectangle “zone”. All parts 
inside the “zone” will be selected. After selecting, you should press “ Accept  “button for 
accessing  the transformation functions for the selected part(s). 
 

A) TRANSFORMATION functions: 
 
1. Moving the part with 2 position   
 

With this function, a part can be moved using 2 cursor positions. The vector from the 
first to the second position will define the translation.  
Steps: 

1. Click on the transform part(s)   button  or Edit->Part->Transform menu 
function   

2. Select the part; Part Transform toolbar will be activated: 

 
3. Define the moving vector after  click on  button; 
4.  Click on “Operation complete” button   

 
 

2. Moving with a fixed value by DX or DY axis  
 

With this function, a part can be moved a desired distance horizontally and/or 
vertically. The operator will be prompted to key in the two distances, first the 
horizontal (negative if left), then a comma and finally the vertical (negative if down). 
The translation will then be instantaneous. 
Steps: 

1. Click on the transform part   button  or Edit->Part->Transform menu 
function   

2. Select the part; Part Transform toolbar will be activated: 

 
3. Input the specific DeltaX and DeltaY values after click on  button; 

Press OK. 
4. Click on “Operation complete” button   
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3. Rotate center  
 

You can freely rotate the part by placing the mouse pointer within its boundaries 
and select the left mouse button. With the left mouse button selected, you should 
make a rotate mouse movement. The part will be rotated and a blue line will be 
shown according with your mouse moving operation.  For finalizing the rotation 
process you should only deactivate the left mouse button. The part will remain 
activated for other arranging functions. 
 
Steps: 

1. Click on the transform part   button  or Edit->Part->Transform 
menu function   

2. Select the part; Part Transform toolbar will be activated: 

 
3. Start rotate the part  after click on button; 
4. Click on “Operation complete” button   

 
4. Rotate the part with a specified angle  
 

You can easy rotate the part with a specific angle. A input rotate angle form will be 
shown. 
Steps: 

1. Click on the transform part   button  or Edit->Part-
>Transform function   

2. Select the part; Part Transform toolbar will be activated: 

 
3. Input the specific rotation after click on  button;Press OK. 
4. Click on “Operation complete” button   

 

 
 

5. Rotate with  fixed angle functions: 90,180,45,-90 degrees 
 

 
When you need to rotate a part, the most used angles are 45,90,-90,180 degrees. For 
easy rotation of the parts, you can use directly the rotate with fixed angle functions 
according with your needs. 
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As result, the selected part will be rotate by a simple left mouse click according with 
fixed angle:,90,180,45,-90 around the current rotation centre 
 
Steps: 

1. Click on the transform part   button  or Edit->Part-
>Transform function   

2. Select the part; Part Transform toolbar will be activated: 

 
3. Rotate the part with the fixed angles  with   

buttons; 
4. Click on “Operation complete” button   

 
6. Rotate “parallel”  

Rotate a part such 2 lines are parallel.  
Steps: 

1. Click on the transform part   button  or Edit->Part-
>Transform function   

2. Select the part; Part Transform toolbar will be activated: 

 
3. Select “rotate parallel” function:  : select the line from other 

part and then select a line from selected part; 

4. Click on “Operation complete” button   
 

7. Mirror  
 

Parts in the nesting sheet can be mirrored horizontally or vertically with the mirror 
functions. 
The part will be mirrored on its center vertical line or horizontal line by a left mouse 
click on the corresponding buttons. 
Steps: 
 

1. Click on the transform part   button  or Edit->Part-
>Transform function   

2. Select the part; PartTransform toolbar will be activated: 
 

3. Mirror part horizontally or vertically with    buttons; 
4. Click on “Operation complete” button   

 
 

B) BUMP functions:  
 

With this function, a part can be moved a distance determined by the system, in 
a specific direction given by the user. The distance is the largest distance the part 
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can be moved without overlapping any other part or the parent plate. Default 
clearances between parts and between a part and the parent plate (sheet)  is taken 
into account when the distance is determined. The clearances between parts or 
between parts and parent plate(sheet) can be modified from Tools->Preference menu  

The BUMP function toolbar is displayed modally and all other transformations 
can be performed at any time.  

 
The parts can be transformed in 8 different directions:  
 
+x along the positive x-axis  

-x along the negative x-axis  
+y along the positive y-axis  

-y along the negative y-axis  
+x +y along the positive x-axis, along the positive y-axis  

+x -y along the positive x-axis, along the negative y-axis  

-x -y along the negative x-axis, along the negative y-axis  

-x +y along the negative x-axis, along the positive y-axis  

 
In the four directions which are a combination of transformations along the x 

and y axes the system alternates between transformations in the x and y directions 
until it is not possible to move the part any further.  

The bump functions can be used in combination with any part transformation. 
 

 
Delete parts from  nesting 
 
Any part on the nesting can be deleted with Edit -> Parts-> Delete function  or 

with  button. The function ask you first to select the part(s), and second to 
confirm the removing of the part from the current nesting job. One or parts can be 
selected by clicking inside of the part or by specify a rectangle window with the 
mouse 

 
 

6.2.4. Parts array 
 
Part(s) can be arranged in a array (matrix) using the Nesting->Array part menu 

function. 
Steps involved: 

1) Select part(s); 
2) Input the number of desired rows/columns; 
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As result, the selected part(s) will be arranged in a matrix according with 
number of rows/columns. 
 

 
 

 
 

6.2.5. Copy part(s) 
A  selected part(s)  can be copied with “Edit->Part->Copy” function or with  
button. The transformation functions can be used after involving copy function. 

6.2.6. Exchange raw plate 
The existing plate of the current nesting job can be changed using  “Edit->Plate-
>Exchange raw plate” menu function or with  button. 
 
For selecting a new nesting job raw plate, two options are available:  

- “Plate by name” : select a existing plate from plate inventory; 
- “Plate by dimension” : input new plate parameters: dimension&quality. 
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6.3. Automatic nesting 
 

SoftONE-NEST offers 2 types of Automatic Nesting: 
a) On the current sheet 
b) On multiple sheet (from plates inventory) 

 
Both option  performs a true shape auto-nesting process. 
 
a) Autonest on the current sheet: 

 
Steps involved: 

 
1) Start a new nesting job; 
2) Load the nested parts in the parts explorer list; 
3) Select the desired parts from PartExplorer;   
4) Start Autonest with from: Nesting->Auto nest->Current sheet function or 

with  button; 
 

b) Autonest on the multiple sheets: 
c)  

1. Load the nested parts in the parts explorer list; 
2. Select the desired parts from PartExplorer;   
3. Start Autonest with from: Nesting->Auto nest->Multiple sheet function; a 

new Autonesting interface will be loaded.  
4. Select the desired plates from plates inventory database. The quantities 

for the selected plates can be changed with a “double-click” mouse on the 
desired plate. 
 

 
The system will start arranging automatically the selected parts from parts explorer 
list according with established parts quantities from Parts Inventory (see Material 
management chapter for more information). The nesting priority is given by the way 
how the parts was ordered in the list: for example, if the list is sorted descending by 
area column, the auto-nest function will start nesting with the bigger area parts to 
smaller parts; if the list is sorted ascending by parts quantities, the system will start 
auto-nesting with the fewest parts to most numbers of parts.  
The user can filter the loaded parts in the list and nest automatically the sequenced 
parts. After finishing, the user can load the other parts and auto-nest it and so on. 
Depending of the user experience, good auto-nesting results can be achieved. 
A mixed manual and auto-nesting is possible as well. You can start a nesting job 
manually and continue nesting process automatic. 
 
Note:The auto-nesting parameters can be changed from Tools->Preference menu 
>AutoNesting 
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5. NC code generation 
 

a. 7.1 Introduction 

Machine specific NC code is not actually generated until the post step. Refer 
to Chapter 7 NC Post Processor for details. This chapter deals with the preparatory 
determination of cutting sequence and the details of the cutting path, using an 
idealized, virtual NC machine. It is assumed that, at this point in the SoftONE-
NEST nesting process, a nesting job has been created and parts have been laid out 
as required, on one or more sheets of material. 
The NC step normally takes place after the nest has been finalized. 
 

b. 7.2 Lead IN/OUT 

Leads are short straight lines at the start and end of a shape. They are used to 
avoid piercing directly on the edge of a part. SoftONE-NEST places leads 
automatically at the appropriate location of a shape. The cutting cycle is started at 
the beginning of the lead-in and terminated at the end of the lead-out; thus ensuring 
that a 'dirty' cut does not ruin the edges of the shapes. 

You can create NC-code with no leads or lead-ins and lead-outs. SoftONE-NEST 
is capable to generate the lead In/Out automatically or manually. 
 
A) Adding the leads automatically 
 
The leads can be added automatically for all parts with Nesting->Starts-> Automatic 
function or by click ob  button The system will add automatically all leads 
according to all processes layers: cutting, marking, labeling.  
 
The default size of  the leads will be used. It can be changed  from  
Tools->Preference->Leads menu function 
 
 
B) Adding the leads manually 
 
The cutting leads can be added also manually with Nesting->Starts->Burn function.  
 
Steps: 
 

1. Select a cutting edge of the part.  
2. Click on “Operation complete” button. 
 
As result, the system will place the lead In and Out at the nearest clicked point 
of the selected edge. If the parts has already the leads added, a warning message 
will be generated. The existing leads will be removed automatically. 
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C) Edit leads 
 
Available edit leads operation are:  

- change size 
- rotate 
- move 
- delete 

 
Change lead steps: 

1.   Click on the transform lead   button or Edit->Leads->Change  ; 
2.   Select the lead; Transform toolbar will be activated:  
3. Change the angle or size with  buttons or  arrows buttons; 
4. Click on “Operation complete” button  . 

 
Move lead steps: 

1. Click on the transform lead   button; 
2. Select the lead; Transform  toolbar will be activated:  

3. Move the lead with  button: you should select other edge of  the part; 
4. Click on “Operation complete” button  . 

 
Delete single lead steps: 

1. Click on the transform lead   button; 
2. Select the lead; Transform toolbar will be activated:  
3. Delete the lead with  button; 
4. Click on “Operation complete” button  . 

 
Delete ALL leads 
You can delete all leads with Edit ->Leads ->Delete ALL function or with  button. 
A confirmation message window will be displayed. 
 

  
 
As result, all leads from the current nesting job will be deleted. 
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c. 7.3 Bridges 

Bridging is a pierce reduction technique that enables the continuous cutting of 
external contours with just one pierce. It creates a small tab between adjacent parts. 
This enables the cutting machine to quickly cut each part without having to lift the 
head—reducing pierce times and stress on the piercing 
 
Adding bridges 
 
The bridges can be added automatic or manually with the Edit ->Bridges-> 
Automatic menu function (  button) or Edit ->Bridges-> Insert  menu functions (  
button).  
 
7.3.1. Manually adding bridges 
 
Normally, for adding a bridge, are necessary to 2 points, one for each part which 
should be connected by the bridge. 
Adding the bridges in SoftONE-NEST is done “semi-automatic” which mean that it 
is necessary to indicate only the desired bridge position and the system will find 
automatically the nearest second point necessary for construct the bridge. 
 
 Steps: 

1. Click on add bridge   button or Edit->Bridge->Insert function; 
2. Indicate the bridge position on a part edge; 
3. Click on “Operation complete” button  . 
 

You can follow up with the 2&3 steps for adding the next bridges as necessary. 
 
7.3.2. Automatically adding bridges 
 
For a fastest bridges adding, SoftONE-NEST can add bridges automatic, which 
mean that no user action are necessary for adding all bridges within a nest job.  
Steps: After finishing the nesting parts, the Edit ->Bridges-> Automatic menu 
function or  buttn should be clicked for adding all bridges automatically for the 
current nesting job. After finishing, you can manually modify the bridge 
arrangement as well. 
 
Delete bridges 
 
You can delete a single bridge or all leads. 
 
Delete a single bridge: 
 
Steps: 

1. Click on the  or Edit->Bridge-> Delete-> Single function; 
2. Indicate the bridge; 
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3. Click on “Operation complete” button  . 
 
You can follow up with the 2&3 steps for deleting the other bridges as necessary 
Delete ALL bridges: 
 
You can delete all bridges with Edit ->Bridges ->Delete ALL menu function or with 

 button. A confirmation message window will be displayed. 
 
As result, all bridges  from the current nesting job will be deleted. 

d. 7.4 Generation of NC files 

After  finalizing the nesting, with or without adding of bridges and leads, the NC 
files for the nestings jobs can be performed. 
SoftONE-NEST generate the NC code automatically according with the machine 
processes in the following order: 

1. Marking lines 
2. Holes 
3. Outside contours 
4. Labels 
5.  

The following types of NC generation functions are available: 
• Complete path : NC code will contain instructions for all type of processes 

found in current nesting 
• Marking path only: NC code will contain instructions only for marking 

processes found in current nesting 
• Cutting path only : NC code will contain instructions only for cutting 

processes found in current nesting 
• Kerf compensation: A tool offset value will be calculated in the final NC code  

according with the nesting plate parameters.  
 
The SoftONE-NEST post processor will optimize the machine paths 

automatically. This will reduce the time spent by machine to complete the nesting 
increasing the production efficiency. 

 
Steps involved: 
 

1. Select the desired machine post processor from Tools->Preference->Post 
Processor menu; 

2. Run the post processor with Generation -> Complete path menu function, or 
with Marking path /Cutting paths/Kerf compensation menu functions as 
desired; 

3. Save the NC code with File -> Save NC code function or click on save NC 
button . 

 
For adding and customizing your own controller setting file for post processing task, 
you should refer to chapter 7, NC Post Processor. 
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8. NC Post Processor 
 

8.1 Introduction 

SoftONE-NEST operates on a wide range of machines with substantially 
different capabilities. For the same nest can be generated different NC code 
according to machine model and controller. SoftONE-NEST uses a controller code 
file for every type of controller to handle the variations. You can modify or make 
your own controller files with any text editor or XML editor or through Preference 
menu, to support any controller. 
 
Definition: 
The post processor in SoftONE-NEST nesting process is the translation of the 
cutting path from SoftONE-NEST’s internal, to the actual codes employed by the 
target machine. SoftONE-NEST support two type of NC output code: ESSI and EIA 
(G-Code) 
  
Locations: 
 
There are two primary groups of files related to the post processor: 

• The definition files include the xml setting files. The post processor setting 
files are locate din the “def” folder of application. These files define the 
machine and determine what NC code is output. 

• The output NC code file that is produced by the post processor operation. The 
NC files can be saved in different location according with the user preference 

8.2 Running the post processor 

For same nesting job can be generated different NC files, according with the selected 
post processor. 
A new post processor can be customized according with your controllers machine 
settings. For post processor settings details, please refer to chapter 7.3 Settings & 
Customization . 
 
Steps involved: 
 

1. Select the post processor file from Tools->Preference->Post Processor tab; you 
can change the settings as necessary; 

2. Generate the NC code from Generation menu functions; 
3. Save the NC code with File->Save NC code function or with  button. 
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8.3 View NC code & simulation 

View NC code: 
 
After successfully complete the post processing, you can view the NC code machine 
instructions  from View->CNC Code function or with  button. 
A new list window  with NC code instructions will appear. 
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A short preview of the NC code will be shown in the simulation toolbar as well: 
 

 
 
 
Simulation: 
 
NC simulation steps through the generated NC code to observe the NC sequence. 
The NC path must be generated before starting the NC simulator. Use the following 
procedure to simulate the NC path: 
 

1. Activate the simulation mode with  View-> Simulate menu function or with 
clicking on  button; Simulation toolbar function will be activated: 
 

 
 

 The following options are available: 
a. Play 
b. Step 
c. Stop 
d. Exit 

 
2. Start simulation of the NC code with “Play” or “Step” button. The processed 

entity will start highlighted with red color according to machine processes; 
The corresponding NC code instruction will be highlighted in the NC code 
list; 
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3. Stop the simulation with the “Stop” button as you need: you can analyze the 

NC code and entities. 
4. Exit from simulation mode with “Exit” button. 
 
 

 
You can speed UP anytime the simulation from the “Play speed” bar: 
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8.4 Settings & Customization 

SoftONE-NEST uses a controller code file for every type of controller to handle the 
variations. You can modify or make your own controller files with any text editor or 
XML editor or through Preference menu to support any controller. 
For creating a new machine XML file, you  can  copy  an existing file with a different  
name in the “def” folder. You can modify it through Preference menu or edit  
manually the XML file.  
 
Post Processor: 
 

 
 
 
Postprocessor: select the desire postprocessor for output the NC files 
Description: edit the description of the postprocessor 
Output extension: modify the extension of the NC file 
Burn Type: select the cutting type by selecting : Gas or Plasma 
Code format Select the code format by clicking Incremental or Absolut 
Controller type: Select the output NC code standard by clicking ESSI or G-Code 
 
NC Processing: 
 
Rapid ON - the code to tell the controller to use fast travel for all further 
movements. Used for ESSI 
Rapid OFF - The code to tell the controller to stop a fast travel 
Plasma ON- The code to tell the controller to use the plasma tool and turn it on. 
Plasma OFF- The code to tell the controller to use the plasma tool and turn it on. 
Gas On The code to tell the controller to use the gas tool and turn it on. 
Gas OFF The code to tell the controller to use the gas tool and turn it off 
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MARK_ON -- The code to tell the controller to turn the marking head on. This can 
be punching, spray paint, inking, or zinc powder marking. 
MARK_OFF -- The code to tell the controller to turn the marking head off. 
MARKOFFSET_ON -- The code to tell the controller to offset the tool head for the 
marking head. 
MARKOFFSET_OFF -- The code to tell the controller to turn the marking head 
offset off. 
LABELING_ON -- The code to tell the controller to turn on  the labeling head. 
LABELLINGOFF -- The code to tell the controller to turn off  the labeling head 
KERF_LEFT -- The code used to offset the torch to the left of the cutting path. 
KERF_RIGHT -- The code used to offset the torch to the right of the cutting path. 
KERF_OFF -- The code used to cancel the torch offset. 
Stop: The code used to stop the machine operations. 
 
Processing settings are used during post-processing when generating the NC code. 
You can modify the instruction taking into account about the settings of your 
machine controller. 
 
Bevel: 
 

 
 
 
Bevel settings are used during post-processing when generating NC code with bevel 
codes. You can modify the instruction taking into account about the settings of your 
machine controller.  
 
For more information about bevel cutting instructions and settings, please send an 
e-mail to office@onesoft.ro 
 

mailto:office@onesoft.ro
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9. Nesting sketches & Reports 
 
 
Production nesting sketch can be generated for all nesting job and contain a sketch 
of the nesting job together with all production information needed for production 
workshop.  
Reports can be generated for a single nesting job or for a group of nesting jobs. Parts 
and plates detailed report (Bill of Materials – BOM) is also available. 
 
All sketches and reports can be printed as necessary with the “File->Print 
functions”. A “Print preview” function is available for these operations as well. 

9.1 Nesting Sketches 

9.1.1 Insert nesting sketch 
 
In SoftONE-NEST, the nesting sketch is generated automatically and contains the 
following production information:  

• Nesting name 
• Project information 
• Plate sheet dimensions 
• Material grade 
• Production info: number of nested parts, burning length, marking length, idle 

length, brutto scrap, weights of the nested parts. 
• Table with parts position numbers are automatically generated. 

 
For inserting a nesting sketch, the nesting job should be ready. 
 
Steps involved: 
 

1. Generate the NC file from “Generation->Complete path” (Marking or Cutting 
path) functions 

2. Insert nesting sketch from Tools->Nesting sketch->Insert Form or from 
button  

 
3. Select the template form from the Sketch lists and click “Insert” button 

 
SoftONE-NEST will change automatically to “Nesting sketch” mode workspace. 
You can easily switch from “Nesting sketch mode” to “Plate nesting mode” with 

 or from Tools->Nesting sketch->Toggle sketch/plate function. 
4. Save the nesting job for storing the sketch in the database. 
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9.1.2 Edit the nesting sketch 
After generate the nesting sketch, you can add your own information according with 
the production workshop  needs. 
For editing the information a sketch, you should go into Nesting sketch mode by 

clicking on  button,  
A new nesting text toolbar will be available: 

 
 
Available functions: 
 
Insert text  
Steps: 

1. Click on the insert text   button   or  Edit->Text->Insert function   
2. Input the text;Press OK. 
3. Place the text in the sketch area according with your needs.  
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Move text   
Steps: 

1. Click on the move text   button   or  Edit->Text->Move function  
2. Select text; the text will be attached to the mouse pointer and you can freely 
move the text. 
3. Place the text in the new position according with your needs.  
 

Copy text   
Steps: 

1. Click on the move text   button   or  Edit->Text->Copy function  
2. Select text; the copy of the selected text will be attached to the mouse pointer 
and you can freely move the new text. 
3. Place the new text in the new position according with your needs.  

 
Modify text  
Steps: 

1. Click on the modify text   button   or  Edit->Text->Modify function   
2. Input the text; Press OK. 
3. Place the modified text in the sketch area according with your needs.  

 
Delete text   
 
Steps: 

1. Click on the move text   button   or  Edit->Text->Delete function  
2. Click on the text which want to be deleted; 

 
 
Change height  
Steps: 

1. Click on the modify text   button   or  Edit->Text->Change-Height  
function   

2. Input the new height; Press OK. 
 
Change angle   
Steps: 

1. Click on the modify text   button   or  Edit->Text->Change Angle function   
2. Input the new height; Press OK. 
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9.1.3 Delete a nesting sketch  
  
The nesting sketch can be deleted with “Tools->Nesting sketch->Delete” The 
operation can be performed only in  Nesting plate mode workspace 
 
 

9.1.4 Creating a Template Sketch 
SoftONE-NEST template project comes with some standard nesting sketches 

template. You can define your own sketch template as follows: 
 
• Open the default SoftONE-NEST dxf nesting sketch with a standard CAD 

program. The sketch is located in the “Sketches” folder of application. 
• You can add your own text or change the company logo according with your 

company needs. The new text should be placed in the default “TEXT1” layer 
in order to be visible in SoftONE-NEST 

 
Please note that the red color texts act as “keywords”, which mean that the 
SoftONE-NEST search for those keywords text when generate the nesting sketch. 
SoftONE use the leywords for automatically adds the production information in the 
production sketch table. 
 

• Save the new modified nesting sketch as DXF giving a new name. 
• Start the SoftONE-NEST application; 
• Import the nesting sketch in the SoftONE-NEST database with “Tools-

>Nesting Form->Import to project DB” function 
 

The new nesting form will be available. 
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9.2 Report, BOM & Nesting Lists 

SoftONE-NEST comes with the following standard reports: 
 

1. Nesting plates – generate nesting job list according with the user nest job 
name filter: 

 

 
 

 
 
Report information: 
Nesting name, plate dimensions, area, weight, quality, density, number of nested 
parts, scrap percent. 
 
2. Nesting parts (BOM) –generate BOM list for the nested parts according with 

the user part name filter: 
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Report information: Part name, position number, block, unit, part area, part 
weight, thickness, working location, side, material grade, nesting information. 
All reports data  can be exported to Microsoft Excel or Adobe Acrobat pdf format 
for easy data sharing across the company departments. 
 
Note: Other customized reports can be deployed upon request according with the 
customer needs. 
 
3. SoftONE-NEST Report  generator can be used for generation of a customized 

Bill of Material .csv files. The user should select the desired csv file columns 
and the column order, as well as the file name and location. Finally, generate 
button  should pe pressed. Available columns are: Part name, part 
position number, number of pc(s), Nesting name, part unit, part area, part 
thickness, part side, part quality, part block and weight. 
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Two reports are generated automatically: Parts reports and Plates report which 
include the nesting job status. 
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10. Appendix 
 
Introduction 
 
This section explains the individual menu commands. 
The user interface consists of several bars and windows: 
 

• Title bar 
• Menu bar 
• Toolbar 
• Parts Explorer tree view 
• Display window 
• Information window 

 
Title bar 
 

 
 
The narrow bar at the top of the screen displays the database name and location and  
the current nesting job. 
 
Information Window: 
Display the production information: 
 

 
 
The following information are available: 
 Nesting dimensions 
 Nesting Quality 
 No of Parts 
 Idle length 
 Burning length 
 Marking length 
 Labeling length 
 Coordinates of the current mouse point on the screen. 
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10.1 FILE Menu 

 

 
 
 
New Nesting job 
 
Initiate a new nesting job. For this operation, the user should input the plate sheet 
name,  dimensions and material quality. 
 
Open Nesting job 
 
Open a nesting job from the current project nesting database. The current project 
database can be changed from  “Tools->Preference” menu as necessary. 
 
Import DXf Parts… 
 
Import a part drawing DXF file into SoftONE-NEST nesting parts database. Nesting 
jobs deals with nesting parts entities, so you should first create the parts before 
start a nesting job. 
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Import Aveva gen Parts 
 
Import Aveva GEN parts data file format (.gen) into SoftONE-NEST nesting parts 
database 
 
Import Aveva DXF Parts 
 
Import Aveva DXF plane parts data file format (ppanparts dxf file) into SoftONE-
NEST nesting parts database 
 
Import SM3D xml parts 
 
Import Smart Marine 3D XML: parts data file format into SoftONE-NEST nesting 
parts database 
 
Change Nesting Status 
 
Change the current nesting job status: pending, complete, in production 
 
Close Nesting 
 
Close current nesting job 
 
Save Nest 
 
Save current nesting job in the database project 
 
Save Nest As… 
 
Save as different name the current nesting job. This operation rename the current 
nesting job as a different name. 
 
Save NC code 
 
Save machine NC code to disk. 
 
Save Plate as DXF 
 
Export current nesting job to DXF file format. The resulted DXF file will contain 
dedicated layers and colors according with machine processes. 
 
Save Sketch as DXF 
 
Export current nesting sketch as DXF file format. 
 
Save ALL 
 
Save All saves as an NC code file and nesting job with “one click” (with the appropriate file 
extensions).  
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Print 
 
Print the current nesting job/nesting sketch, according with the current workspace mode. 
 
Print Preview 
 
Preview the the current nesting job/nesting sketch before printing. You can print it directly from 
the print preview window. 
 
Exit 
 
Exit from SoftONE-NEST application. 
 

10.2 EDIT menu 

 
 
Part/Shape - Functions:  

Transform Perform a part geometrical transformation in the current nesting 
job:  

 Delete   Remove a part from current nesting.  
 Properties show the part production information 
 
Plate – Functions: 

Exchange Raw Plate: Change the plate material dimensions, quality and 
thickness for the current nesting job 

 
Leads - Functions: 

Change: interactive  change the lead angle and/or the lead length. :  
 Delete all leads: delete all starts from the current nesting; 
 
Bridges 
 Insert: Add a bridge between 2 nested parts 
 Delete: Delete a single or all bridges in the current nesting job. 
 Automatic: Add bridges between parts in the nesting job. 
 
Bevel: 
 Perform bevel operation on the selected part. 
 
Text: Nesting Sketch Functions: 
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 Insert: Insert a text; 
Move: Move a text to a new position; 
Copy: Copy a text row; 
Modify: Change the text contents; 
Delete : delete a text; 

 Change: change a height or angle of text. 
 
 

10.3 VIEW Menu 

 
 
Zoom IN  
Zoom magnifies a selected area. Select the area by dragging a zoom window 
enclosing the area to magnify (the hot key for this function is Z). 
 
Pan  
Pan moves the drawing about the screen (hot key W). 
 
Zoom All  
Zoom All displays the entire drawing on the screen (hot key A). 
 
Repaint 
Refresh the current drawing. 
 
Nest Explorer:  
Show or hide the part explorer tree view which contains detected nested parts. 
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Info bar 
Show or hide the info bar situated at lower bottom side 
 
Toolbars 
Show or hide the application Toolbars : Standard Toolbar, NC Information Toolbar, 
Transform Parts Toolbar, Text Toolbar 
 
CNC Code 
Bring a new window on the screen with NC code for easy visualization of NC  
Code 
 
Simulate 
Simulate the machine paths on the screen: 

 
 
Play, Stop, Step toolbar buttons are available for easy analyzing of NC code. 
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10.4 NESTING Menu 

 
 
Nest Parts Functions: 

- By Name: Get the parts from database for nesting. Part filters can be 
used for a fastest part selection. 

- From Part Explorer: Parts can be selected fro nesting a part explorer 
list Get the  

 
Transform Part:  
Select parts for applying geometrical transformation or BUMP translation. 
 
Check Collisions  
Check the interference between parts in the current nesting job 
 
Start - Functions: 
 Automatic: Add leads In/Out to all nested parts in the current nesting 
.automatically. 
 Burn: Add a single burning start to a nested part in the current nesting. 
 
Autonest: 
Start auto nesting function which perform automatic nesting of the parts selected in 
the parts explorer list. 
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10.5 GENERATION Menu 

 

 
 
Complete path 
Generates the NC code  with optimization of the machine paths. This operation run 
the SoftONE-NEST post processor for automatically generation of the NC code for 
the current nesting. 
For more information see “NC code generation” chapter. 
 
Marking Path 
Similar with “Complete path” but generate only the marking paths. 
 
Cutting path 
Similar with “Complete path” but generate only the burning(cutting) paths. 
 
Kerf Calculation 
Generate the tool offset path. This function create a parallel contour for all 
geometries on the cutting layer at specified kerf value. The parallel tool offset 
contour will be calculated for the input kerf value divided by 2. 
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10.6 TOOLS Menu 

 

 
 
 
Dimension : Distance 
Perform a distance calculation between 2 points.  
 

 
 
Information displayed: distance between points in mm, delta X, delta Y. 
 
 
Shape Info  
Show information about selected object in a “InfoTool” window. First, user must 
select a geometry.  
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Information displayed: Part name, shape type, Start/End Points, Bevel type/side 
 
 
 
Nesting Sketch   
 Insert: Generate a sketch for current nesting. Toggle button between plate 
and sketch can be used for easy display of the nesting plate or drawing sketch. 
 Delete: Delete the current nesting sketch 
 Toggle Sketch/Plate : Show the nested plate or sketch on the main 
application window 
 
Reports : 
Launch the reports generator: 
 Nesting plate report: generate the nesting plate list; 
 Nested parts report: generate Bill of Materials report (BOM); 

BOM – Generate Bill of Materials in csv file format. 
 
See the Nesting Sketch & Reports chapter for details. 
 
Nesting Form: 
Import a customized user DXF nesting sketch into SoftONE-NEST database. 
 
Material 

Quality Density: Add or edit the materials qualities and densities; 
Parts Inventory: Store a part list with necessary parts quantities; 
Plates Inventory: Stores a list of all the plates stored at the facility. 

 
DB Utility 
Launch the DB Utility Admin tool 
 
Preference:  
Show the application preference window for change the application and controller 
settings.   
 
Option 
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Show the option settings window.  

 

 

Idle : change the color used for display on the main screen for idle geometries layer. 
Marking : change the color used for display on the main screen for mark geometries 
layer. 
Cutting : change the color used for display on the main screen for cutting geometries 
layer. 
Background : change the color used for background main screen  color 
 
HELP Menu 
Launch the application help file. 
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10.7 CONTEXT Menu 

 
“Context menu” functions can be accessed using a mouse right click in the main 
application window. No new functions are implemented here. Each context menu 
function represents a shortcut to specific menu item. The icon used for each item is 
shown also in the menu and corresponding toolbar items.  
Please note that depending of the current work space (nest or sketch) some functions 
are not available. 
 

 
 
 
 
Main Display Window – Work Space: 
The large center window displays the geometry of the path. The left tree view 
control show the nested parts. Colors are used to distinguish between the different 
functions of the geometric entities.  
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10.8 TOOLBARS 

The tool bars are located, by default, at the top of the screen underneath the Pull-
down Menu. Their positions can be rearranged around the edge of the graphics area 
by dragging them to the desired position. 

 

 
 
Each button represents a shortcut to a menu item. The icon used for each toolbar is 
shown also in the menu at the corresponding function.  
Please note that the parts geometric  transformation and BUMP toolbar functions 
are available only in the corresponding toolbars. 
 
 
A tool tip (a text message that describes the function of the button) appears if you 
rest the cursor over a button for a short time 
 
 
 
 
***************************************************************************** 
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